Please enable JavaScript to view this site.

After performing an appropriate analysis on that data. To access this feature, simply click on the toolbar button located in the Draw section of the toolbar (or select the menu item "Pairwise Comparisons" from the Insert menu).

Pairwise Comparisons Toolbar Button

 

Which analyses have comparisons that Prism can plot automatically?

T tests

Comparisons from all variants (paired/unpaired, parametric/non-parametric) can be added automatically.

One sample t test and Wilcoxon test

These are only available when there are no subcolumns in the data, or (if there are subcolumns) the default option "Average the replicates in each row" is selected.

One-way ANOVA

All options for multiple comparisons following all variants (paired/unpaired, parametric/non-parametric) can be added automatically.

Two-way ANOVA

Multiple comparisons that compare individual cell means (but not comparisons of entire rows/columns) can be added automatically. Appropriate multiple comparisons for two-way ANOVA include:

Compare each cell mean with the other cell mean in that column (only available for two-way ANOVA with exactly two rows)

Compare each cell mean with the other cell mean in that row (only available for two-way ANOVA with exactly two columns)

Within each row, compare columns (simple effects within rows)

Within each column, compare rows (simple effects within columns)

Compare cell means regardless of rows and columns

 

Format Pairwise Comparisons dialog

After performing an appropriate analysis (or re-calculating an appropriate analysis from an older version of Prism), clicking the toolbar the first time will automatically add lines and asterisks for all comparisons included in the analysis for that data set. Most of the time, that's all you'll need to do!

However, if you'd like to customize the appearance of the comparison lines/brackets, clicking on the toolbar button a second time (or double clicking on one of the comparison lines) will bring up the Format Pairwise Comparisons dialog.

Format Pairwise Comparisons Dialog

On the first tab (Appearance) of this dialog, you can choose to display numeric P values or asterisks, you can specify a cutoff threshold for which P values to display on the graph, or you can customize the appearance of all of the displayed comparison lines.

The second tab (Comparisons on Graph) of this dialog allows you to select specific comparisons to display or hide on the graph. By default, all comparisons defined by the analysis are displayed on the graph.

 

Formatting individual comparison lines

To change the settings of a single comparison line, simply right-click on the line you would like to customize. From the menu that appears, you can choose to change:

Text font, color, size, and appearance

Line color, thickness, and style

Title position (for vertical graphs, this controls if the text is above or below the line. For horizontal graphs, this controls if the text is to the left or right of the line.)

For horizontal graphs, you can also choose for the text direction to be either "up" or "down"

Note that all of these items can also be applied to multiple comparison lines simultaneously. Simply click and drag to select multiple lines, or click multiple lines while holding the shift key on your keyboard before applying the custom settings.

 

Selecting the test to display

Prism will only automatically display comparisons from a single analysis. If you've performed more than one of the tests listed above on the graphed data set (it's unlikely that this would be required or - in some cases - even appropriate), you'll need to identify which test includes the comparisons you'd like to display. If you decide later that you want to display comparisons from a different test performed on the same data, you can choose which analysis results to display from the dropdown menu on the Comparisons on Graph tab of the Format Pairwise Comparisons dialog.

Format Pairwise Comparisons - Comparisons on Graph Tab

 

Removing Pairwise Comparison lines from your graph

If you decide you no longer want the comparison lines on your graph, there are a number of ways that they can be removed. To remove a single comparison line, you can select the line to be removed by clicking it, then simply pressing the "delete" key on your keyboard. Alternatively, you can open the Format Pairwise Comparisons dialog, switch to the Comparisons on Graph tab, and deselect the desired comparison(s) in the list there.

To remove ALL comparison lines from the graph, click on the dropdown portion of the Pairwise Comparisons toolbar button and select "Remove Pairwise Comparisons". Alternatively, you can open the Change main menu, select "Pairwise Comparisons", and then select "Remove Pairwise Comparisons". Note: this will not simply hide the comparison lines. This removes them from the graph and erases any custom appearance settings that had been applied to them.

 

Data from multiple data tables on a single graph

This feature works only when there is data from a single data table displayed on the graph. Comparisons will not be shown on a graph if it contains data from more than one data table

 

 

 

 

 

 

 

 

 

© 1995-2019 GraphPad Software, LLC. All rights reserved.