GraphPad Prism 8 User Guide

Embedding or linking Prism graphs in other programs

Embedding or linking Prism graphs in other programs

Previous topic Next topic No expanding text in this topic  

Embedding or linking Prism graphs in other programs

Previous topic Next topic JavaScript is required for expanding text JavaScript is required for the print function Emails questions or corrections.  

This page applies only to Prism Windows. Object Linking and Embedding is not possible on the Mac. We wish it were.

The difference between pasting an object, a link or a picture

There are three ways to copy a Prism graph or layout and paste it into many Windows programs, including Word or PowerPoint.

Paste a graph or layout as a Prism object:

Prism will paste a picture of the graph, plus a copy of all the data, analyses and graphical settings needed to create that graph (or layout).

Double-click the object in the other program to edit it within Prism, where you can edit data, change analysis settings, and format the graph. When you exit Prism, the revised graph will appear in Word.

The advantage of embedding is that the Word or PowerPoint file is complete, containing the Prism data and settings. One disadvantage is that this makes the Word file larger. Another disadvantage (for some) is that it means your data can be stored in multiple places. If you realize the data was entered incorrectly, you will need to edit all the copies. Others see this as an advantage -- a way to backup your data.

A Prism object only includes the data tables and results that are linked to the graph (or layout) that you pasted. Other parts of the Prism project are not included.

This is Windows only, and is not possible with Prism Mac.

Consider creating a drawing canvas in Word

In Word (but not PowerPoint) you can go to Insert, Shapes and select "New Drawing Canvas". That "canvas" is an area where you can combine images. Paste in a Prism graph, add text, import images, insert shapes and equations.... If you insert those items individually right on the page, they get entangled with flowing text. Putting them into a canvas keeps them together and away from the flowing text, and lets you control their arrangement with one another. Learn more.

Paste a graph or layout as a picture

A picture may be worth a thousand words, but it doesn't let you edit data, change analysis choices or reformat the graph. When you double-click on a pasted picture, you cannot edit it within Prism. Instead, you'll open up a generic graphic or photo editor.

An advantage of this approach (for some) is that people you send the file to won't be able see your data or edit your graphs. Because there is no need to store the data and settings, this approach doesn't take up so much disk space.

Paste a graph or layout as a link

Prism can paste a picture along with a link to the Prism file. When you double-click, Prism will be launched and open the linked Prism project. You can then edit the data, analysis settings, or graph in Prism. When you exit, the revised graph will be updated in Word or PowerPoint.

One advantage of this method (over pasting an object) is that your Word or PowerPoint files will be smaller. Another advantage (for some) is that it keeps your data in one place for easy editing. The disadvantage is that the link really is just a link to a file with a particular name in a particular place. If the linked file has been deleted, renamed or moved, you won’t be able to edit it. If you move the Word or PowerPoint to another computer, you won't be able to open the linked file unless it too is moved.

This is Windows only, and is not possible with Prism Mac.

Insert object

If you insert a Prism object into Word or PowerPoint, you'll embed an entire Prism project. In contrast when you paste a graph as an object, you only embed the data and results linked to that graph.

Choose the Insert Object command from the other program's Insert menu (or in Office 2007, the right side of the Insert tab). Choose to create object from a file, and choose your Prism file.

The advantage of this method is that it includes the entire Prism project. This might be useful if you send a document to a colleague and want to include all supporting details.

This is Windows only, and is not possible with Prism Mac.

 

How to choose to paste an object, a link or a picture

One-click buttons to send to PowerPoint or Word

Choices in the Send to MS Office tab of Prism's preference dialog determine whether Prism's one-click Send buttons send an object, a link, or a picture.

Copy and paste

When you copy a graph (or layout), Prism put all the necessary information on the clipboard so the pasting program can choose if it wants to paste a picture, an object, or a linked picture. Microsoft Word and Excel and older versions of PowerPoint paste an embedded object. PowerPoint 2007 and 2010 are different. By default, they paste a picture. To override this, drop the clipboard menu,  choose Paste Special, and then choose to paste a Prism object.

Copy and Paste Special

Instead of pasting (and letting the program choose), use the Paste Special command, so you can choose which format is pasted. With most programs, Paste Special is a choice on the Edit menu. With Office 2007 and 2010, it is a choice on the Paste menu which is on  the left side of the Home tab of the ribbon.

The Paste Special dialog lets you choose to paste an object ("GraphPad Prism 8 Project Object"), or a Picture ('Enhanced metafile"). You can also paste a bitmap, which might be useful if you want this Word or PowerPoint document to look nice on a Mac.

If you check this option to paste a link, the scrolling list gives you no choices. This option will not be available if you copy a graph from an unnamed Prism project, because linking requires that the Prism file has a name.

EMF+, EMF(old) or WMF?

Windows supports three similar formats for describing images using vectors and fonts. The WMF (Windows Metafile) format is older. The EMF+ (Enhanced metafile) format is newer, and in theory a bit better. Prism can also use an older version of EMF. In fact, one format works better for some programs and the other format for others. It seems impossible to predict.

Choose which format to place on the clipboard (and to use when sending graphs to PowerPoint) at the bottom of the File & Printer tab of the preferences dialog. If you're having problems with pasted graphs looking funny, try another format.

Editing a Prism object embedded in PowerPoint or Word

To edit a Prism object embedded in PowerPoint or Word, simply double click on it.

If you have multiple versions of Prism installed on your computer, Windows will choose which version to launch (the one used to create that object). But you can override that decision: Right click on the Prism object in PowerPoint, choose the Prism Object command, and then choose Convert from the submenu, and choose the Prism version you want to open that object.

Opening Prism objects with different Prism versions

What happens when you double click on a Prism object embedded in Word or PowerPoint (or elsewhere)? If the Prism version that created that object is present on your computer, that version of Prism will open it. If that version is not present, a newer version of Prism will open the file. But if the object was created with Prism 7, but the computer only has Prism 6, the object will not open. Instead you'll see a message that explains.

After editing in Prism, updating the object in Word or PowerPoint

After editing an object in Prism, you'll want to push those changes to the program that holds the object, usually Word or PowerPoint. There are three ways to do this:

Close Prism completely. To do this, click the "X" at the upper right of the Prism window. Or drop the File menu and choose Exit.

Close the Prism "file" containing the object, but don't close Prism entirely. To this click the smaller "X" button at the upper right of the Prism window, just below the one that closes Prism entirely. Or drop the File menu and choose "Close and Return to ...".

Close the Prism "file" containing the object, but don't update PowerPoint or Word. Ignore your changes, and leave Word or PowerPoint as they are. To do this, drop File and choose "Close But Don't Update..."

Update the object in PowerPoint or Word while still leaving it open in Prism. To do this, click the Save button in Prism, or use the Control-S keyboard shortcut.