GraphPad Prism 8 User Guide

Working with multiple files in Prism Mac

Working with multiple files in Prism Mac

Previous topic Next topic No expanding text in this topic  

Working with multiple files in Prism Mac

Previous topic Next topic JavaScript is required for expanding text JavaScript is required for the print function Emails questions or corrections.  

Distinguish multiple sheets in one project file from multiple files

A Prism project can have multiple pages or sheets, divided into five sections. These are all saved in one Prism .PZF or .PZFX file. Of course, you can export individual data tables or graphs, but this is not the same as saving the entire project as one Prism file.

People new to Prism often make the mistake of thinking that each Prism file can only have one data table and one graph. Not so. Each file can contain up to 500 data tables, info sheets, analysis results, graphs and page layouts.

One window per file (usually)

Normally each Prism window contains one Prism file (but see below). If you have used Prism for Windows (prior to Prism 8)  you used one master window that could hold multiple child windows, one for each file. This multiple document interface has never been supported on Macs.  

When you create or open multiple files with Prism Mac, it usually looks like this. Each project file is in its own window with its own toolbar.

clip0024

 

What are tabbed windows?

A new feature in MacOS Sierra lets you put several files into one window and navigate between them using tabs.  This is a great way to work on multiple files at once, especially on a small screen. Apple calls this feature Tabbed Windows.

If you use MacOS Sierra or later, you work with multiple Prism files in  one window. Drop the Window menu on any of the Prism files, and choose "Merge All Windows".

clip0102

Now there is only one Prism Window, with a set of tabs just below the toolbar that let you choose which project file you are working on:

clip0143

Putting multiple files in one tabbed window is simply a convenience to make it a bit easier to move between files. The files are still all distinct, saved in different names. Putting multiple files into one tabbed window does not merge the files.

Working with tabbed windows

To create a new tab for a new (or existing) file, click the + button to the right of the file selection tabs which will create a new tab and bring up the Welcome dialog so you can choose a file to open or begin to create a new file.

There are three ways to move a file into its own window and away from the tabbed window:  Control-click on the tab and choose Move Tab to New Window; grab the tab and drag it away from the joint window; or drop the Window menu and choose Move Tab to New Window.

A window that contains only one project file usually doesn't show the tab bar. To show it, drop the View menu (in Prism) and choose the first choice "Show Tab Bar". When you have two or more Prism windows showing the tab bar, you can drag tabs from one window to another (even on different displays).

Keyboard shortcut: Hold Control and click Tab to move to the next project file in the tabbed window. Hold shift and control and click tab to go to the prior project file.

Preference for newly created or opened Prism files

When  you already have a Prism window open, what happens when you open another file or create a new file? It depends on a setting in the Dock tab of the system Preference dialog, "Prefer tabs when opening documents". (Note this setting is in the system preferences dialog, not in Prism's preference dialog.) There are three settings.

Always.  When you open or create a file, it will be added to a new tab on the open Prism window and will not create a new window.

In full screen mode only. If you have maximized the Prism window to full screen, opening or creating files will add a new tab to the existing window. If you are not in full screen mode, new and opened files will be placed in new windows.

Manually. New files (and newly opened files) always go into new windows unless you use the + button to the right of the last tab to create a new one.

 

Closing a Prism file

There are two ways to close a Prism file.

Click the red circle at the upper left of the Prism window. This will close the file and also close the window. If you only have one Prism window open, this will quit Prism. If that window has multiple files in tabs, all will close.

Drop the File menu and choose Close. Or use the Command-W shortcut. This will close the file you are working on but not other open files. It will leave Prism running, ready to open or create another Prism file. when you drop its File menu.