GraphPad Prism 8 User Guide

Preferences

Preferences

Previous topic Next topic No expanding text in this topic  

Preferences

Previous topic Next topic JavaScript is required for expanding text JavaScript is required for the print function Emails questions or corrections.  

Overview

Use the Preferences dialog to set Prism's defaults for various settings.

Note that some preference settings are made elsewhere in Prism. The import (paste special) dialog, the export graph, and the diagnostics tab of nonlinear regression, for example, all have check-boxes to make the current settings default for the future.

Also note that on Macs, there are two settings in the General tab of the System preferences dialog that have a big effect on how Prism works.

To open the Preferences dialog, drop the Edit menu (Windows) or Prism menu (Mac) and choose Preferences.

default2

Most of the settings are self explanatory. The rest of this page discusses the settings that are not entirely self-explanatory.

 

View tab

Reset zoom. If you zoom to make a graph or layout larger or smaller and then view a different graph or layout, what happens? Keep the same zoom, or reset to a default zoom?

Antialiasing. Prism uses antialiasing to improve the appearance of graphs on screen. When curves or lines are drawn in black on a white background, antialiasing fills in gray pixels in the corners to reduce the jagged look. Prism Mac gives you no choice. Prism Windows offers an option to turn of antialiasing, which improves the look on some old computers. Note that antialiasing only affects the appearance of graphs and layouts on screen those exported or copied in EMF+ format, but has no effect on the appearance of printed graphs or those exported in WMF, EMF(old), PDF, EPS, PNG or JPG formats.

Default fonts.

Inches or cm?

Autocomplete titles after you type the first few characters?

Show alerts on graphs with missing error bars, points off scale, etc. ? Untl Prism 7, these alerts tended to be long and a bit annoying. Prism 8 makes then much shorter, but you can turn them off altogether if you want to.

 

File and Printer tab: Automatic backup

Choose to backup whenever you move to a different sheet and by timer every K minutes (you specify K). For Windows, you can also ask Prism to backup files when you close a file and choose not to save it (it will show on Welcome dialog).

Read more about autobackup.

 

File and Printer tab: File format

Default to saving in PZF orPZFX format.

If you use PZF format, do you want to use the compact style? All this format does is leave out analysis results (and instead recomputes them when you open the file).  It makes the file a bit smaller, but PZFX files are way smaller. PZFX files never include analysis results which always need to be recalculated when you open the file.

 

File and Printer tab: Print options

When Printing tables, choose whether to print grid lines and column titles.

For all printing, deciding whether you want a header with file name, date and time.

 

File and Printer tab: Copy to clipboard options

How to copy graphs and layouts to clipboard (Windows). Prism gives you a choice of three formats: WMF, EMF (old) and EMF+. In theory, EMF+ is the best because it is newest. But it all depends on which application you are pasting into. You may need to experiment.

How to paste a graph from another project (Mac). Choose whether the pasted image needs to be Windows compatible (which increases file size, and on slow computers may noticeably delay pasting).

When copying a graph or layout, include the background color or not. If you choose not to include the background color, the background will be clear (transparent). How that looks depends on what you are pasting onto. This option applies when copying a graph or layout to the clipboard. If you use Send to Powerpoint instead, Prism always makes the graph or layout transparent so the PowerPoint background shows through.

When copying numbers, what to do with missing values. They can be left blank, be pasted as numbers followed by an asterisk, or pasted as regular numbers.

Use comma or period as the decimal separator.

When copying numbers where Prism knows more decimal places than it shows on screen, paste all the digits or just those shown on screen.

 

 

New Graphs tab

Set defaults for axes, error bars, symbols and lines, color schemes, and graph and data table fonts. These defaults apply to newly created graphs, but don't change existing graphs. 

 

Analysis tab

Most analysis options are set on the various analysis tabs which have a check box to make those settings the default for future analyses. Not all anlayses, and not all tabs in the analysis dialogs offer this choice.

There is only one choice in Preferences. Many analysis tabs give you a choice for how to format P values. These choices offer a choice to show N digits after the decimal, where you set N. The preference tab lets you choose the default N and to choose when/if to use scientific notation.

Info sheets tab

Choose whether to create an Info table (for entry of meta data and notes) for each new data table, and what items to include by default.

File locations

Set the default location for saving Prism files, for importing/exporting data, importing/exporting graphs and layouts, scripts and templates. Note that templates are saved to, and read from, folders within the folder you specify but not in that folder itself.

Send to Office (Windows only)

Prism has buttons to send a graph or layout to Word or PowerPoint, and you can set several options for how this is done.

Services tab

Option to automatically check for updates and let you know if there is one. Also an option to create an extended log file to troubleshoot unusual problems.