KNOWLEDGEBASE - ARTICLE #2196

Prism 9.0.1 Release Notes

Last modified January 26, 2021

Prism 9.0.1 was released on January 26, 2021. Browse prior versions

Apple M1 Native Support

Prism 9.0.1 for macOS is available as a universal binary that will run natively on both Macs with Intel chips as well as Macs with Apple M1 chips. This FAQ contains more information about Prism and Apple's M1 chips (and macOS BigSur).

Feature Improvements

  • Enabled the "Line and error go..." dropdown options for "Violin plot with all points" in the Format Graph dialog
  • Enabled the autocomplete feature for legend titles on Bubble Plots
  • Implemented labels variable for Biplots (instead of using row titles)
  • Added the choice "None" for border thickness of continuous color legends so that it is now possible to disable the legend border on multiple variable graphs
  • Added variable type icons in dropdown menus with variables in analysis parameters dialogs
  • Added the multiply or divide (but it looks like a star) unicode character (22C7) to the math section of Prism's Insert Character dialog
  • Added a floating note on the results sheet when using the Extract and Rearrange analysis for Contingency data in the case when input values were negative or non-integer
  • Added a floating note (instead of alert) for graphs that are incompatible with pairwise comparisons
  • Updated the tooltip for connecting lines on multiple variable graphs with "Connect points by group" option to display the source data table and current group
  • Updated the wording in the Data arrangement tab of the "Extract and Rearrange" analysis
  • Updated all radio buttons to appear in an inactive (gray) state in the "Show additional ticks" section of the "Format Axes" dialog when no tick or line or label was entered in the additional ticks and gridlines block
  • Updated the option "Define Color Scheme..." to be inactive (gray) in contextual menus of multiple variables graphs if the option "One color for entire graph" was selected in the "Format Graph" dialog
  • Changed the default number of points to interpolate from 0 to 1 on the "Interpolation" tab of the "Parameters: Multiple Linear Regression" dialog
  • (Win) Changed "Data sets" to "Categories" on the Format Graph dialog for multiple variables graphs
  • (Win) Removed tooltips for connecting lines on multiple variables graphs (when "Connect points by group" option is not selected)
  • (Win) Added the color pop-up menus for largest and smallest values when using the "Grayscale" color map in the "Format Graph" dialog for multiple variables graphs
  • (Mac) Implemented native support of Apple Silicon CPU. Now Mac Prism is supplied as a Universal Binary which runs natively both on Intel and Apple CPUs
  • (Mac) Made the "Insert characters" toolbar button open the same menu that Insert > Character does, thus showing the Insert Unicode command on the toolbar
  • (Mac) Enabled the "Insert Character" button in the Column/Variable Titles tab of the Format Data Table dialog
  • (Mac) Added "Ticks" options in the "Labels" tab of the "Format Graph" dialog for Heatmaps
  • (Mac) Made it possible to change the fill color and pattern for multiple variable graph legends from the contextual menu
  • (Mac) Made it impossible to edit labels of categorical size legends on multiple variable graphs
  • (Mac) Enabled the "Reverse legend order" option for the Color legend of multiple variable graphs
  • (Mac) changed the minimum Mac Prism system requirements to macOS 10.12
  • (Mac) Made it impossible to perform the "Multiple Linear Regression" analysis from Survival data tables
  • (Mac) Disabled the "Change analysis parameters" toolbar button for graphs with no linked results

Performance Improvements

  • Improved the performance of the "One-way ANOVA" analysis with pairwise comparisons
  • (Win) Improved performance of pasting column titles from MS Excel into Prism data tables
  • (Mac) Significantly improved undoing of deleting 100 rows in all-categorical multiple variables data tables containing a large number of values (19k rows, 800 columns)
  • (Mac) Improved performance slightly of AUC analysis
  • (Mac) Improved performance slightly of opening Prism file with a large number of data points compared to 9.0.0
  • (Mac) Improved performance of switching to simulated XY data table with 256 data sets and 256 replicates

Analysis Bug Fixes

  • Fixed the issue in which unexpected results appeared for PCR if the corresponding dependent variable contains too few points
  • Fixed the issue in which incorrect transform results appeared when using the logic statement "0/0" to return blank values
  • Fixed the issue in which the wrong total DF and labels for parameter estimates were displayed in the results of multiple linear regression when not fitting an intercept term
  • Fixed the issue in which nonlinear regression would get stuck on interpolating X from Y if the fit was unsuccessful
  • Corrected the results in "Hougaard's Measure of Skewness" section of nonlinear regression results if some results were shared
  • Fixed the issue in which some user-defined transform equations did not work
  • Fixed the issue in which a variable was incorrectly added to the main effects of model definition of multiple linear and logistic regression after inserting a new column into the source data table
  • Fixed the issue in which a column with transformed results did not appear in the Select and Transform results for custom equations
  • Fixed the issue in which the results of multiple linear regression, multiple logistic regression, select and transform, and extract and rearrange analyses unexpectedly changed after deleting or inserting a new column (variable) between existing columns in the source data table
  • Fixed the issue in which multiple t test calculations could not be interrupted
  • Fixed the issue in which user-defined equations that use IF statements were handled incorrectly
  • Fixed the issue in which Prism would crash when performing the "Select and Transform" analysis of categorical variables with more than 108 unique levels
  • (Win) Fixed the issue in which the "Classification table" of "Multiple logistic regression" results was not updated after changing the dependent (or outcome) variable in the parameters dialog
  • (Win) Fixed the issue in which the logistic plot graph was empty if it was created from Multiple logistic regression analysis with a single (continuous) predictor
  • (Win) Fixed the issue in which Prism would crash on an attempt to select the variable in the "Select rows" tab of the "Parameters: Select and transform" analysis after unchecking it in the "Analyze Data" dialog
  • (Win) Fixed the issue in which the "Value" edit field in the "Select rows" tab of the "Parameters: Select and transform" dialog did not save its value
  • (Win) Fixed the issue in which it was not possible to hook constant values to constrained parameters in the Nonlinear regression analysis
  • (Win) Fixed the issue in which the option "Make these choices the default for future fits" did not save selected "Unstable parameters and ambiguous fits" choice for "Nonlinear regression" analyses
  • (Mac) Fixed the issue in which the floating note "Note that new variable(s) added to the data table are not included in the model" did not appear in Multiple linear regression results sheets after adding a new variable
  • (Mac) Fixed the issue in which results of Multiple linear and logistic regression analyses were unexpectedly changed after inserting a new column (variable) between existing columns (variables) in the source data table
  • (Mac) Fixed the issue in which an equation was unexpectedly replaced after adding a new equation with the same name and different content to the list of user-defined functions for the Transform parameters dialog
  • (Mac) Fixed the issue in which it was impossible to recalculate Bland-Altman results sheets after excluding a data set

Graphing Bug Fixes

  • Fixed the issue in which an XY graph created in Prism 8 appeared as a grouped graph after opening it in Prism 9
  • Fixed the issue in which bars disappeared from Interleaved bars graphs if a Frequency distribution graph was created after performing Nonlinear regression analysis on the Frequency distribution results sheet
  • Fixed the issue so that it is impossible to add a right Y axis for multiple variables graphs through the "Magic" command while the example graph contains only a right Y-axis or both Y axes enabled
  • Fixed the issue in which Prism ignores the white choice in the "Open symbols" dropdown in the "New Graphs" tab of the Preferences dialog
  • Fixed the issue in which the "with changes" preview for multiple variables graphs appeared corrupted in the "Magic Step 2" dialog if "Legend" was checked and the source multiple variables graph was segmented on the X/Left Y axis
  • Fixed the issue in which a multiple variables graph appeared without the left Y-axis after using the 'Magic' tool if the example graph contained only the right Y-axis
  • Fixed the issue in which the floating note "This data was created using an older version of Prism" unexpectedly appeared after re-opening the project with all excluded data in any variable
  • Fixed the issue in which a categorical color legend box on a multiple variables graph was unexpectedly resized after increasing font size if it had previously been decreased for one of the legend labels
  • (Win) Fixed the issue in which the "<=" and ">=" symbols were rendered incorrectly in graph legends and titles
  • (Win) Fixed the issue in which the "μ" symbol unexpectedly reverted to a "u" after exiting edit mode in a graph legend
  • (Win) Fixed the issue in which an incorrect value appeared when inserting a "One-way ANOVA" analysis constant on a graph
  • (Win) Fixed the issue in which the X-axis title on a graph was reverted to the initial title after deleting some of the symbols in the title
  • (Win) Fixed the issue in which the X-axis title font style on a graph was reverted to the initial one after changing it
  • (Win) Fixed the issue in which part of a multiple variables graph was missing from the plotting area after performing the "Magic" operation if the example graph had a segmented X/Left Y-axis
  • (Win) Fixed the issue in which some symbols disappeared from a multiple variables graph after performing the "Magic" operation if the example graph from another graph family had a segmented Y-axis
  • (Win) Fixed the issue in which heatmaps appeared empty after unfreezing them in a re-opened Prism project if a data set was previously excluded in the source data table
  • (Win) Fixed the issue in which multiple variables graphs were shifted left each time the "Format graph" dialog was closed when the color and size legends overlapped each other
  • (Win) Fixed the issue in which the left Y-axis title was misplaced on multiple variables graphs after changing the graph from "Two segments" to "Standard" for logarithmic scale
  • (Win) Fixed the help page link in the "Cannot add pairwise comparisons" alert
  • (Win) Fixed the issue in which labels on multiple variable graphs appeared disproportionately large after zooming in if row titles were used as labels
  • (Win) Fixed the issue in which labels on multiple variable graphs appeared extremely small after copying a graph to a different application
  • (Win) Fixed the issue in which the choice "Enter or import data into a new table" was not selected by default after using it in the Welcome dialog
  • (Win) Fixed the issue in which Japanese and Chinese characters in row titles were omitted in labels on multiple variable graphs
  • (Win) [Japanese] Translated the default title of Biplots ("Biplot") generated by PCA
  • (Win) [Japanese] Fixed the issue in which asterisk (*) symbols were displayed as "?" when using automatic pairwise comparisons and line-with-text objects
  • (Mac) Fixed the issue in which colors were unexpectedly changed after entering them in RGB or Hex format for drawing objects in the Format Object dialog
  • (Mac) Fixed the issue in which Prism would crash when switching to Heatmaps
  • (Mac) Fixed the issue in which Prism would crash when performing the "Magic" function for Heatmaps
  • (Mac) Fixed the issue in which PCA graphs appeared empty after performing the "Redo" operation if the "Undo" operation was previously performed for the visited PCA results sheet
  • (Mac) Fixed the issue in which the fill color legend of multiple variables graphs appeared corrupted after changing the default color of the largest value for the Grayscale colormap
  • (Mac) Fixed the issue in which the incorrect preview for a Bubble Plot was shown in the "Change Graph Type" dialog if "Single Color" and/or "Single Size" parameters were selected
  • (Mac) Fixed the issue in which the text "n more hidden" in multiple variable graph legends was truncated after performing the "Center on page" arrangement action

Other Bug Fixes

  • Fixed the issue in which Prism would crash when attempting to open the "Parameters: Multiple Linear Regression" dialog for orphaned results sheets with a specified number of points to interpolate
  • Fixed the typo in the "Plateau" title in the equation sheet of the "Plot a function" analysis
  • Fixed the issue in which the serial number for R licenses were not accepted by Prism if previously Prism used a different license type
  • Fixed Prism so that the size of symbols in the Size drop-down in the Format Graph dialog now corresponds to symbol sizes on the graph
  • Fixed the issue in which variables containing only titles were lost during export to XML
  • Fixed the issue in which the wrong levels were added to the levels list for a categorical variable in auto mode upon deleting the symbols in the level name if there was only one level within the variable
  • Fixed the issue in which variables with the "Auto" type were unexpectedly reset to "Continuous" upon reopening Prism
  • (Win) Fixed the issue in which Prism would crash when attempting to create a data table with Multiple variables sample over an already existing (non MV) empty data table by clicking the "Table format" button in the data table
  • (Win) Fixed the issue in which Prism would crash when attempting to paste data copied from Excel into a Prism data table
  • (Win) Fixed the issue in which it was impossible to export multiple layouts at a time from gallery mode for layout sheets
  • (Win) Fixed the issue in which the highlight cell toolbar button disappeared when the "Scale" level in the system "Display Settings" dialog was set to more than 100%
  • (Win) Fixed the issue in which it was impossible to move a graph using the up arrow key
  • (Win) Fixed the issue in which an unexpected results sheet was created after applying the Magic tool
  • (Win) Fixed the issue in which Pairwise comparisons disappeared on layouts pasted into MS Office and Adobe Illustrator
  • (Win) Fixed the issue in which Prism would crash when using the Magic tool
  • (Win) Fixed the issue in which changes of values in a MS Excel spreadsheet would not propagate to a linked graph or layout sheet in Prism
  • (Win) Fixed the issue in which it was impossible to scroll horizontally in data tables (and other places) using a mouse with a scroll wheel dedicated for horizontal scrolling
  • (Win) Fixed the issue in which Unicode symbols copied from the system "Character Map" dialog to data set titles in a data table looked corrupted in dropdown menus in the "Analyze data" and analysis parameters dialogs, graph axes, and graph labels
  • (Win) Disabled the "Reverse legend order" checkbox in the "Size" sub-section of the "Legends" section of the multiple variables Format Graph dialog if the "Show legend" checkbox was unchecked
  • (Win) Fixed the issue in which no automatic floating note was shown when there were missing data for multiple variables graphs
  • (Win) Fixed the unexpected "Disk or memory error occurred" alert that appeared after deleting duplicated results sheets from Multiple linear or logistic regression and PCA analyses
  • (Win) Fixed the issue in which Prism would crash after deleting duplicated "Select and Transform" results sheets
  • (Win) Fixed the issue in which Prism would crash while attempting to disable the border for the continuous color legend on multiple variables graphs using the Format Object dialog
  • (Win) Fixed the issue in which Prism would crash when selecting an additional vertical gap for heatmaps
  • (Win) Fixed the issue in which it was impossible to copy a graph with pairwise comparisons to the Clipboard using Ctrl+A and Ctrl+C shortcuts
  • (Win) Fixed the issue in which the registry entry for Prism 8 was not removed in system Programs and Features when performing quite command-line Prism 9 installation with the option to uninstall Prism 8
  • (Win) Fixed the issue in which "Multiple linear regression" results appeared empty if the source table was deleted with the option to delete all linked sheets
  • (Win) Fixed the issue in which colormap transparency for multiple variables graphs was reset to 0% in the Format Graph dialog after changing the built-in colormap to a different one
  • (Win) Fixed the issue in which asterisks entered into multiple variable data tables to denote excluded values were unexpectedly replaced with "[n]*" if the variable type was set to "Continuous (Auto)"
  • (Win) Fixed the issue in which Wingding characters were replaced with dots in the "Create New Graph", "Change Graph Type", "Format Graph" dialogs for multiple variables graphs
  • (Win) [Chinese] Fixed the issue in which toolbar tooltips were not displayed correctly
  • (Mac) Fixed the issue in which Prism would crash when opening a file from Windows Prism 9 with a Three-way graph created by the "Normalize" analysis
  • (Mac) Fixed the issue in which Prism would crash upon opening a project with a graph with custom tick lines and graphs with column separators
  • (Mac) Fixed the issue in which Prism would crash when attempting to open a file created in Prism 8.4.3 with a grouped interleaved graph
  • (Mac) Fixed the issue in which Prism would crash when attempting to save a project with a user-defined equation in the "Nonlinear regression" analysis
  • (Mac) Fixed the issue in which Prism would freeze when attempting to change the "largest symbol" value to a value smaller than the "smallest symbol" value (and vice versa) in the "Format Graph" dialog for multiple variable graphs
  • (Mac) Fixed the issue in which an entered value with an asterisk was recognized as an excluded value in the Multiple variables data table
  • (Mac) Fixed a number of rendering issues in dialogs displayed with macOS 11.0 Big Sur
  • (Mac) High DPI. Fixed the corruption of labels in the Format Graph dialog for the Grouped graph
  • (Mac) Fixed the size of the "Parameters: Multiple t tests (and nonparametric tests)" dialog
  • (Mac) Fixed the issue in which thumbnails with connecting lines unexpectedly appeared enabled while the "Show connecting lines" checkbox was disabled in the "Lines" tab of the "Format Graph" dialog invoked for multiple variables graphs
  • (Mac) Fixed the issue in which the "You have not entered the right kind of data for this analysis" alert was not shown while attempting to open the "Parameters: Principal Component Analysis" dialog for data in a table other than Multiple variables
  • (Mac) Fixed the issue in which the "Display Options" section appeared active in the "Format Graph" dialog after double-clicking on the fill color/size legend of a multiple variables graph
  • (Mac) Fixed the issue in which an unexpected thousands separator appeared in the "Custom" edit field for the value of the smallest symbol after re-invoking the "Format Graph" dialog for multiple variables graphs if >= 1000 values were entered
  • (Mac) Fixed the issue in which the "Legends on Graph" label in the "Display Options" tab of the multiple variables Format Graph dialog inconsistently appeared inactive (gray) while options were available on this tab
  • (Mac) Fixed the issue in which Prism would crash while switching to "Interpolation" results if data were previously removed from the source table and the table type was changed to Survival
  • (Mac) Fixed the issue in which the floating note about categorical variables containing more than 500 unique levels was not removed after updating the data table
  • (Mac) Fixed the issue in which the "autofill" feature did not work for categorical variables of multiple variables data tables if a value was excluded
  • (Mac) Fixed the issue in which the "Viridis" colormap appeared instead of "Grayscale" colormap after re-opening the "Format Graph" dialog if the largest and smallest values were previously changed
  • (Mac) Fixed the issue in which Prism would crash when assigning Color and Size variables with data sets from newly added non-multiple variables data tables via the Format Graph dialog for multiple variables graphs if previously a multiple variables data table was deleted
  • (Mac) Fixed the issue in which all unique levels of a categorical variable did not disappear from the second scrollbar section in the "Variable Types" tab of the "Format Data Table" dialog while a filtered view was set for continuous or label variables
  • (Mac) Fixed the issue in which Prism would crash when clicking OK or Apply in the multiple variables Format Graph dialog after clearing labels of categorical color legend for multiple variables graphs
  • (Mac) Added the "%" sign near the "Transparency" value in "Fill Color" and "Connecting Line Options" tabs of the "Format Graph" dialog for multiple variables graphs
  • (Mac) Added the "%" sign near the "Percentile level" parameter in the Options tab of the "Parameters: Principal Component Analysis" dialog if the "Other..." item was selected in the dropdown menu
  • (Mac) Fixed the issue in which Prism would crash after deleting values from "Prefix" and "Suffix" in the "Legend" section of the multiple variables Format Graph dialog
  • (Mac) Fixed the issue in which column titles were not shown fully in data tables from multiple variables sample data
  • (Mac) Fixed the issue in which an X column in a data table was too narrow to fit default gray titles
  • (Mac) Fixed the issue in which an empty item was selected in the "Style" dropdown menu for all categories after this option was changed for a particular group of connecting lines in the "Format Graph" dialog for multiple variables graphs
  • (Mac) Fixed the issue in which Prism unexpectedly treated values as excluded in graphs and analyses if data were imported with a link, chose to not exclude values preceded or followed by asterisks, and changed the variable type to "Auto"
  • (Mac) Fixed the issue in which the wrong levels were displayed in the levels list for a categorical variable in "Auto" mode in the Variable Types tab of the Format Data Table dialog upon editing a multi-line level name in the data table
  • (Mac) Fixed the issue in which long variable names in the source data table led to increasing the "Format Graph" dialog width when switching to the "Connecting Line Options" or "Label Options" sections
  • (Mac) Fixed the issue in which the option "its row titles" was unexpectedly enabled in the "Label Options" section of the Format Graph dialog for multiple variable graphs
  • (Mac) Fixed the issue in which checkboxes in the "Properties to apply" section in the "Magic Step 2" dialog unexpectedly appeared enabled if a heatmap graph was used as an example
  • (Mac) Fixed the issue in which short [N] variable names did not appear in the variables dropdown menu in the "Output" tab of the "Parameters: PCA" dialog if the source data table contained variable titles
  • (Mac) Fixed the issue in which newly checked/unchecked variables unexpectedly saved their state after clicking the Cancel button in the PCA dialog
  • (Mac) Fixed the issue in which the OK button unexpectedly appeared enabled after unchecking variable on the "Data" tab of the PCA dialog if the "Inspect the parameters..." radio button was previously selected in the "This results sheet is frozen" dialog
  • (Mac) Removed the alert about an inability to launch Prism on low resolution displays
  • (Mac) [macOS 11.0 (Big Sur)] Fixed an unexpectedly empty Design dropdown for patterns in the Appearance tab of the Format Graph and Format Object dialogs
  • (Mac) [macOS 11.0 (Big Sur)] Fixed the issue in which the Style line dropdown in the Format Object dialog contained corrupted choices
  • (Mac) [macOS 11.0 (Big Sur)] Fixed the rendering of the toolbar in Prism's preferences

Explore the Knowledgebase

Analyze, graph and present your scientific work easily with GraphPad Prism. No coding required.