KNOWLEDGEBASE - ARTICLE #2194

Known issues for Prism 8 on macOS 11.0 (Big Sur)

Last modified November 24, 2020

There are three known issues in Prism 8 on macOS 11.0 (Big Sur). These issues have been fixed in Prism 9, so we encourage you to update Prism.

Prism crashes on clicking the "Clone a Graph" button in "Welcome" or "New Data Table and Graph" dialogs. Fixed in Prism 9.0.0

Some controls in the Prism preferences dialog appear cut and collapsed. Fixed in Prism 9.0.0

Items are invisible in Design dropdown for patterns in Appearance tab of Format Graph and Format Object dialogs. Will be fixed in Prism 9.0.1 (Coming soon)

 

Prism crashes on clicking the “Clone a Graph” button in “Welcome” or “New Data Table and Graph” dialogs

Fixed in Prism 9.0.0

This problem occurs when you choose the "Clone a Graph" tab in the "Welcome" or "New Data Table and Graph" dialogs.

Cloning is the process of duplicating a specified graph sheet along with the data tables and results sheets that are used to generate that graph (for example, when cloning an XY graph with a plotted dose-response curve, the graph sheet, the XY data table containing the data, and the nonlinear regression sheet would all be duplicated). From the Welcome dialog, you can choose to clone graph sheets in currently opened Prism documents, recently used Prism documents, saved files, or shared example files.

Workarounds:

  • Duplicate a family of sheets. When a graph sheet is selected in the Navigator, choosing to duplicate its family is identical to cloning the selected graph. To duplicate a family of sheets in this way, first select the graph sheet in the Navigator, then do one of the following:
    • Click the "New" toolbar button, and choose "Duplicate Family..." in the dropdown menu
    • Open the Insert menu and choose "Duplicate Family..."
    • Open the Family menu and choose "Duplicate Family..."
    • Right click (or control+click) on the sheet in the Navigator and select "Duplicate Family..."

These steps will result in a new family of sheets being added to the existing (open) Prism project file. More information on Duplicating a family of sheets can be found here.

  • Save Family. After selecting the graph sheet you would like to duplicate, open the Family or File menu and choose "Save Family as...". Alternatively, you can right click (control+click) on the word Family at the top of the Family Navigator panel and select "Save Family as...". This will result in a new Prism project file being created that contains only the selected family of sheets. More information on how Families of sheets working Prism can be found here.
  • Using the Magic function. Saved and shared example graphs can be viewed, moved/renamed, and deleted via the Magic dialog which can be invoked either via the toolbar button or by opening the Change menu and selecting "Magic. Make Graphs Consistent...". More information on using the Magic tool in Prism can be found here.

Some controls in the Prism preferences dialog appear cut or collapsed

Fixed in Prism 9.0.0

This is a visual-only issue. The corresponding options are still visible and clickable. However, they may appear slightly corrupted. As an example, see the option in the Autocomplete section of the View tab of the Preferences dialog below.

Items are invisible in Design dropdown for patterns in Appearance tab of Format Graph and Format Object dialogs

Will be fixed in Prism 9.0.1 (Coming soon)

Items can be chosen and applied, but they are invisible. See the screenshots below for examples:

Workaround:

Use the contextual menu from the graph

  1. Select an object (or data set) on the graph
  2. Right-click (or control+click) on the object (or data set) to invoke the contextual menu
  3. Select Format This Bar, Format Entire Data Set, etc.
  4. Choose the desired Fill Pattern from the corresponding dropdown menu



Keywords: Prism 8 macOS Big Sur

Explore the Knowledgebase

Analyze, graph and present your scientific work easily with GraphPad Prism. No coding required.